Can't view the order in Magento 2 admin

  • Last Post 11 June 2019
rajeev posted this 08 May 2019

I placed an order using GFS checkout and tried to view in the admin but it is throwing an error. Note: Order status was pending, didn't check in processing status yet.


1 exception(s):
Exception #0 (Exception): Notice: Undefined index: selectedService in /chroot/home/homescap/ on line 123

Exception #0 (Exception): Notice: Undefined index: selectedService in /chroot/home/homescap/ on line 123
<pre>#1 JustShout\Gfs\Block\Adminhtml\Order\View\Info\Gfs->getServiceTitle() called at [generated/code/JustShout/Gfs/Block/Adminhtml/Order/View/Info/Gfs/Interceptor.php:76]
#2 JustShout\Gfs\Block\Adminhtml\Order\View\Info\Gfs\Interceptor->getServiceTitle() called at [app/code/JustShout/Gfs/view/adminhtml/templates/order/view/info/gfs/standard.phtml:7]
#3 include() called at [vendor/magento/framework/View/TemplateEngine/Php.php:59]
#4 Magento\Framework\View\TemplateEngine\Php->render() called at [vendor/magento/framework/View/Element/Template.php:271]
#5 Magento\Framework\View\Element\Template->fetchView() called at [vendor/magento/framework/Interception/Interceptor.php:58]
#6 JustShout\Gfs\Block\Adminhtml\Order\View\Info\Gfs\Interceptor->___callParent() called at [vendor/magento/framework/Interception/Interceptor.php:138]
#7 JustShout\Gfs\Block\Adminhtml\Order\View\Info\Gfs\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/framework/Interception/Interceptor.php:153]
#8 JustShout\Gfs\Block\Adminhtml\Order\View\Info\Gfs\Interceptor->___callPlugins() called at [generated/code/JustShout/Gfs/Block/Adminhtml/Order/View/Info/Gfs/Interceptor.php:442]
#9 JustShout\Gfs\Block\Adminhtml\Order\View\Info\Gfs\Interceptor->fetchView() called at [vendor/magento/framework/View/Element/Template.php01]
#10 Magento\Framework\View\Element\Template->_toHtml() called at [vendor/magento/module-backend/Block/Template.php:129]

Order By: Standard | Newest | Votes
rajeev posted this 15 May 2019

Update to the above question;
I placed a real order and the order status is processing but again getting this exception error when I tried to open the order in Magento admin. This error is in Magento 2.2.6 to 2.3.1 all versions.No one can launch the website until this is fixed.

Simon Wilson posted this 11 June 2019

Hi Rajeev,


as discussed via Email this has been resolved by you doing some work and this will be resolved in our latest release of the module which is due to be made available in the 2-4 weeks.

I will keep you updated on this separately.


Best regards